A weekly comic about programming, browsers and geek stuff.

Happy Holidays

Merry browserful Christmas and Happy browserful New Year 2017!
https://comic.browserling.com/extra/18
Cartoon tags:
christmas, new year, merry christmas, happy new year, happy holidays, browser, browsers, opera, safari, chrome, firefox, internet explorer, ie, christmas tree, browser tree, 2016, 2017, advisors, investors, panda, unicycle, google, snow
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING18 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.